summaryrefslogtreecommitdiffstats
path: root/examples/opengl/legacy/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-04 10:41:57 +0200
committerFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-07 07:22:17 +0000
commitd8c3375dbd0bc4327c4da3df2433f965058d1da8 (patch)
treec2886dd0baf5a27c0d35bcb6fb0b949d8ea68274 /examples/opengl/legacy/CMakeLists.txt
parent331d1cf9fdeaf0d95ac601c460ebcd3e77de8376 (diff)
cmake: add examples/opengl
Fixes: QTBUG-78164 Change-Id: Iccc8bb1354d2362c950de17a6c00e00f95272967 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'examples/opengl/legacy/CMakeLists.txt')
-rw-r--r--examples/opengl/legacy/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/examples/opengl/legacy/CMakeLists.txt b/examples/opengl/legacy/CMakeLists.txt
new file mode 100644
index 0000000000..5f98186a0e
--- /dev/null
+++ b/examples/opengl/legacy/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Generated from legacy.pro.
+
+if(NOT TARGET Qt::OpenGL)
+ return()
+endif()
+if(NOT QT_FEATURE_dynamicgl AND NOT QT_FEATURE_opengles2)
+ add_subdirectory(grabber)
+ add_subdirectory(hellogl)
+ add_subdirectory(overpainting)
+ add_subdirectory(pbuffers)
+ add_subdirectory(framebufferobject2)
+ add_subdirectory(samplebuffers)
+endif()