summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/imagescaling/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2020-11-09 16:44:26 +0100
committerSona Kurazyan <sona.kurazyan@qt.io>2020-11-12 08:56:14 +0100
commit190b77463d40db0278919992912d48d1e96e4796 (patch)
tree995fb829020824d55a45dc2083ce1590a79a62e0 /examples/qtconcurrent/imagescaling/CMakeLists.txt
parentcc3f693029d6fcc65a0153b658061bd121a6af66 (diff)
Improve QtConcurrent ImageScaling example to demo new features
In order to demonstrate the new functionality, changed the example to download the images from the network, scale and show them by attaching different continuations to QFuture. Because QtConcurrent::map is not used anymore, removed the suspension functionality (supporting suspension of download would complicate the logic). Task-number: QTBUG-87205 Change-Id: I5a48b63195d28025ae8c5de28bc6d6178dad03db Reviewed-by: Paul Wicking <paul.wicking@qt.io> Reviewed-by: Jarek Kobus <jaroslaw.kobus@qt.io>
Diffstat (limited to 'examples/qtconcurrent/imagescaling/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/imagescaling/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/qtconcurrent/imagescaling/CMakeLists.txt b/examples/qtconcurrent/imagescaling/CMakeLists.txt
index b1065e877b..caca16da12 100644
--- a/examples/qtconcurrent/imagescaling/CMakeLists.txt
+++ b/examples/qtconcurrent/imagescaling/CMakeLists.txt
@@ -19,8 +19,10 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Concurrent)
find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS Network)
qt_add_executable(imagescaling
+ downloaddialog.cpp downloaddialog.h downloaddialog.ui
imagescaling.cpp imagescaling.h
main.cpp
)
@@ -32,6 +34,7 @@ target_link_libraries(imagescaling PUBLIC
Qt::Concurrent
Qt::Core
Qt::Gui
+ Qt::Network
Qt::Widgets
)