summaryrefslogtreecommitdiffstats
path: root/examples/qtestlib/tutorial1/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/qtestlib/tutorial1/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/qtestlib/tutorial1/CMakeLists.txt')
-rw-r--r--examples/qtestlib/tutorial1/CMakeLists.txt35
1 files changed, 23 insertions, 12 deletions
diff --git a/examples/qtestlib/tutorial1/CMakeLists.txt b/examples/qtestlib/tutorial1/CMakeLists.txt
index 6e489e329f..b30293a3e3 100644
--- a/examples/qtestlib/tutorial1/CMakeLists.txt
+++ b/examples/qtestlib/tutorial1/CMakeLists.txt
@@ -1,16 +1,27 @@
# Generated from tutorial1.pro.
-#####################################################################
-## tutorial1 Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(tutorial1 LANGUAGES CXX)
-add_qt_executable(tutorial1
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/qtestlib/tutorial1"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/qtestlib/tutorial1"
- SOURCES
- testqstring.cpp
- LIBRARIES
- Qt::Widgets
- Qt::Test
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+find_package(Qt5 COMPONENTS Test)
+
+add_executable(tutorial1 WIN32 MACOSX_BUNDLE
+ testqstring.cpp
+)
+target_link_libraries(tutorial1 PUBLIC
+ Qt::Test
+ Qt::Widgets
+)
+install(TARGETS tutorial1
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)