summaryrefslogtreecommitdiffstats
path: root/examples/vulkan/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-04 10:39:26 +0200
committerFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-07 07:22:09 +0000
commit331d1cf9fdeaf0d95ac601c460ebcd3e77de8376 (patch)
treec18d983d67be3cec8f274d070d2a3e12e31fe1b4 /examples/vulkan/CMakeLists.txt
parenta5946296022cf6dc26f5f83997b5c1e3f7ef5748 (diff)
cmake: add examples/vulkan
Fixes: QTBUG-78216 Change-Id: Id7d936ab0b3febc6b7ad3170ec2ea67836484217 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'examples/vulkan/CMakeLists.txt')
-rw-r--r--examples/vulkan/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/vulkan/CMakeLists.txt b/examples/vulkan/CMakeLists.txt
new file mode 100644
index 0000000000..b00a40447a
--- /dev/null
+++ b/examples/vulkan/CMakeLists.txt
@@ -0,0 +1,11 @@
+# Generated from vulkan.pro.
+
+add_subdirectory(hellovulkanwindow)
+add_subdirectory(hellovulkantriangle)
+add_subdirectory(hellovulkantexture)
+if(TARGET Qt::Widgets)
+ add_subdirectory(hellovulkanwidget)
+endif()
+if(TARGET Qt::Concurrent AND TARGET Qt::Widgets)
+ add_subdirectory(hellovulkancubes)
+endif()