summaryrefslogtreecommitdiffstats
path: root/examples/widgets/animation/easing/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-20 13:41:37 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 15:25:39 +0000
commitaa50b377a7d904e35cf3a26e4c8a054108011ffd (patch)
treeff45946e5779357aa547f00a8b5b9d0119a2b8f2 /examples/widgets/animation/easing/CMakeLists.txt
parent05ebd62f099b51b160a06e1257007bf437355fae (diff)
CMake: Add widgets examples
Change-Id: Ib6142b93df066e3658eb189b50ca74c455fe7e56 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/animation/easing/CMakeLists.txt')
-rw-r--r--examples/widgets/animation/easing/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/widgets/animation/easing/CMakeLists.txt b/examples/widgets/animation/easing/CMakeLists.txt
new file mode 100644
index 0000000000..ba391d082b
--- /dev/null
+++ b/examples/widgets/animation/easing/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from easing.pro.
+
+#####################################################################
+## easing Binary:
+#####################################################################
+
+add_qt_executable(easing
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/easing"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/easing"
+ SOURCES
+ animation.h
+ form.ui
+ main.cpp
+ window.cpp window.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(easing "easing" FILES
+ images/qt-logo.png)
+