summaryrefslogtreecommitdiffstats
path: root/examples/widgets/desktop/systray/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/widgets/desktop/systray/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/desktop/systray/CMakeLists.txt')
-rw-r--r--examples/widgets/desktop/systray/CMakeLists.txt41
1 files changed, 23 insertions, 18 deletions
diff --git a/examples/widgets/desktop/systray/CMakeLists.txt b/examples/widgets/desktop/systray/CMakeLists.txt
index 9f5d05e751..2e89c2a8f9 100644
--- a/examples/widgets/desktop/systray/CMakeLists.txt
+++ b/examples/widgets/desktop/systray/CMakeLists.txt
@@ -1,23 +1,28 @@
# Generated from systray.pro.
-#####################################################################
-## systray Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(systray LANGUAGES CXX)
-add_qt_executable(systray
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/desktop/systray"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/desktop/systray"
- SOURCES
- main.cpp
- window.cpp window.h
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-# Resources:
-add_qt_resource(systray "systray" PREFIX "/" FILES
- images/bad.png
- images/heart.png
- images/trash.png)
+set(INSTALL_EXAMPLEDIR "examples")
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(systray WIN32 MACOSX_BUNDLE
+ main.cpp
+ systray.qrc
+ window.cpp window.h
+)
+target_link_libraries(systray PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS systray
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)