summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/chip/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 08:15:50 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 18:50:39 +0000
commit76108058796bf0884f6fd128d81f1bc49f9a56af (patch)
tree1c5f0740ca3217f3d11cf7c684143bbb0da0f336 /examples/widgets/graphicsview/chip/CMakeLists.txt
parent465949420a877099247d94dd4db54d19ca5a9a7c (diff)
Regenerate examples
Change-Id: I04b2adbe370ffea81d7787ad90e4ae69d2c165cb Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/widgets/graphicsview/chip/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/chip/CMakeLists.txt35
1 files changed, 28 insertions, 7 deletions
diff --git a/examples/widgets/graphicsview/chip/CMakeLists.txt b/examples/widgets/graphicsview/chip/CMakeLists.txt
index 302a8a56ca..41af2553ee 100644
--- a/examples/widgets/graphicsview/chip/CMakeLists.txt
+++ b/examples/widgets/graphicsview/chip/CMakeLists.txt
@@ -9,27 +9,48 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/widgets/graphicsview/chip")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
find_package(Qt6 COMPONENTS OpenGL) # special case
find_package(Qt6 COMPONENTS PrintSupport) # special case
add_qt_gui_executable(chip
chip.cpp chip.h
- images.qrc
main.cpp
mainwindow.cpp mainwindow.h
view.cpp view.h
)
target_link_libraries(chip PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Widgets
)
-if (TARGET Qt::OpenGL)
- target_link_libraries(chip PUBLIC Qt::OpenGL)
-endif()
-if (TARGET Qt::PrintSupport)
- target_link_libraries(chip PUBLIC Qt::PrintSupport)
+
+
+# Resources:
+set(images_resource_files
+ "fileprint.png"
+ "qt4logo.png"
+ "rotateleft.png"
+ "rotateright.png"
+ "zoomin.png"
+ "zoomout.png"
+)
+
+qt6_add_resources(chip "images"
+ PREFIX
+ "/"
+ FILES
+ ${images_resource_files}
+)
+
+if(TARGET Qt::PrintSupport)
+ target_link_libraries(chip PUBLIC
+ Qt::PrintSupport
+ )
endif()
install(TARGETS chip