summaryrefslogtreecommitdiffstats
path: root/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 08:15:50 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 18:50:39 +0000
commit76108058796bf0884f6fd128d81f1bc49f9a56af (patch)
tree1c5f0740ca3217f3d11cf7c684143bbb0da0f336 /examples/widgets/mainwindows/mainwindow/CMakeLists.txt
parent465949420a877099247d94dd4db54d19ca5a9a7c (diff)
Regenerate examples
Change-Id: I04b2adbe370ffea81d7787ad90e4ae69d2c165cb Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/widgets/mainwindows/mainwindow/CMakeLists.txt')
-rw-r--r--examples/widgets/mainwindows/mainwindow/CMakeLists.txt24
1 files changed, 22 insertions, 2 deletions
diff --git a/examples/widgets/mainwindows/mainwindow/CMakeLists.txt b/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
index f4f8bdb4ca..3152fb0904 100644
--- a/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
+++ b/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
@@ -9,20 +9,40 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/widgets/mainwindows/mainwindow")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(mainwindow
colorswatch.cpp colorswatch.h
main.cpp
- mainwindow.cpp mainwindow.h mainwindow.qrc
+ mainwindow.cpp mainwindow.h
toolbar.cpp toolbar.h
)
target_link_libraries(mainwindow PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Widgets
)
+
+# Resources:
+set(mainwindow_resource_files
+ "qt.png"
+ "titlebarCenter.png"
+ "titlebarLeft.png"
+ "titlebarRight.png"
+)
+
+qt6_add_resources(mainwindow "mainwindow"
+ PREFIX
+ "/res"
+ FILES
+ ${mainwindow_resource_files}
+)
+
install(TARGETS mainwindow
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"