summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/affine/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-20 13:41:37 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 15:25:39 +0000
commitaa50b377a7d904e35cf3a26e4c8a054108011ffd (patch)
treeff45946e5779357aa547f00a8b5b9d0119a2b8f2 /examples/widgets/painting/affine/CMakeLists.txt
parent05ebd62f099b51b160a06e1257007bf437355fae (diff)
CMake: Add widgets examples
Change-Id: Ib6142b93df066e3658eb189b50ca74c455fe7e56 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/painting/affine/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/affine/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/widgets/painting/affine/CMakeLists.txt b/examples/widgets/painting/affine/CMakeLists.txt
new file mode 100644
index 0000000000..cda43296dd
--- /dev/null
+++ b/examples/widgets/painting/affine/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from affine.pro.
+
+#####################################################################
+## affine Binary:
+#####################################################################
+
+add_qt_executable(affine
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/affine"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/affine"
+ SOURCES
+ main.cpp
+ xform.cpp xform.h
+ # INCLUDE_DIRECTORIES ../shared # special case
+ LIBRARIES # special case
+ painting_shared
+)
+
+# Resources:
+add_qt_resource(affine "affine" PREFIX "/res/affine" FILES
+ bg1.jpg
+ xform.cpp
+ xform.html)