summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/deform/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-27 12:07:51 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-27 19:26:45 +0100
commit638ac41293da9c6ae5e4ccb9baa7819c772ba9dd (patch)
tree0d0aa42f2fbbacc42b874d460c0e9a796a93c271 /examples/widgets/painting/deform/CMakeLists.txt
parentf65abc63441bf821c4e4619b842c74b6d5074cbd (diff)
CMake: Fix painting examples to build as standalone projects
The examples use an intermediate object library to avoid duplicate file compilation. The examples worked when built as part of Qt because the shared directory was always added, and Qt::OpenGL is available implicitly. Change each project to add_subdirectory(../shared) if the object library is not available, thus making the examples build as standalone projects. Call find_package inside the shared project, to ensure the Qt packages are found. Create an alias called 'painting_shared::painting_shared' and link against that to ensure that any failure is caught at configure time rather than build time. Adapt the pathstroke example to use the object library. Comment out the code for the OpenGL scopes, because it's handled by the object library. Make sure the OpenGL dependency is public. Make sure to run moc and compile the OpenGL specific files as well. Task-number: QTBUG-87444 Change-Id: Ib0ecb68948581c5267ca04f19d8043fa44ff3d54 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/widgets/painting/deform/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/deform/CMakeLists.txt27
1 files changed, 18 insertions, 9 deletions
diff --git a/examples/widgets/painting/deform/CMakeLists.txt b/examples/widgets/painting/deform/CMakeLists.txt
index 61b28f1b3a..c2517ac66f 100644
--- a/examples/widgets/painting/deform/CMakeLists.txt
+++ b/examples/widgets/painting/deform/CMakeLists.txt
@@ -37,11 +37,17 @@ target_include_directories(deform PUBLIC
../shared
)
+# special case begin
+if(NOT TARGET painting_shared::painting_shared)
+ add_subdirectory(../shared painting_shared)
+endif()
+# special case end
+
target_link_libraries(deform PUBLIC
Qt::Core
Qt::Gui
Qt::Widgets
- painting_shared # special case
+ painting_shared::painting_shared # special case
)
@@ -209,15 +215,18 @@ qt6_add_resources(deform "deform"
${deform_resource_files}
)
-if(QT_FEATURE_opengl)
- target_sources(deform PUBLIC
- ../shared/fbopaintdevice.cpp ../shared/fbopaintdevice.h
- )
+# special case begin
+# remove files from ../shared
+#if(QT_FEATURE_opengl)
+ #target_sources(affine PUBLIC
+ #../shared/fbopaintdevice.cpp ../shared/fbopaintdevice.h
+ #)
- target_link_libraries(deform PUBLIC
- Qt::OpenGL
- )
-endif()
+ #target_link_libraries(affine PUBLIC
+ #Qt::OpenGL
+ #)
+#endif()
+# special case end
install(TARGETS deform
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"