summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/gradients/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2021-12-08 16:42:09 +0100
committerKai Koehne <kai.koehne@qt.io>2021-12-13 14:16:26 +0000
commit51f22a3a0495d8418a5d6dd0f09771c0347441b9 (patch)
tree34b5c133cd5e808e98c63b1e801400b716e34d9d /examples/widgets/painting/gradients/CMakeLists.txt
parent9ca7429dff4b5d46114ca36147f65b61d5e61290 (diff)
Examples: Remove remaining conversion markers in CMakeLists.txt
Pick-to: 6.3 Change-Id: Ia5d474a3efd6aadbd0ef1537318f2f24e6c24fee Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/painting/gradients/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/gradients/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/examples/widgets/painting/gradients/CMakeLists.txt b/examples/widgets/painting/gradients/CMakeLists.txt
index 62dca0045d..6de1d3c47e 100644
--- a/examples/widgets/painting/gradients/CMakeLists.txt
+++ b/examples/widgets/painting/gradients/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from gradients.pro.
-
cmake_minimum_required(VERSION 3.16)
project(gradients LANGUAGES CXX)
@@ -18,12 +16,10 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/painting/gradients")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
qt_add_executable(gradients
- # special case begin
# remove files from ../shared
#../shared/arthurstyle.cpp ../shared/arthurstyle.h
#../shared/arthurwidgets.cpp ../shared/arthurwidgets.h
#../shared/hoverpoints.cpp ../shared/hoverpoints.h
- # special case end
gradients.cpp gradients.h
main.cpp
)
@@ -35,17 +31,15 @@ target_include_directories(gradients PUBLIC
../shared
)
-# special case begin
if(NOT TARGET painting_shared::painting_shared)
include(../shared/use_lib.cmake)
endif()
-# special case end
target_link_libraries(gradients PUBLIC
Qt::Core
Qt::Gui
Qt::Widgets
- painting_shared::painting_shared # special case
+ painting_shared::painting_shared
)
@@ -108,7 +102,6 @@ qt_add_resources(gradients "gradients"
${gradients_resource_files}
)
-# special case begin
# remove files from ../shared
#if(QT_FEATURE_opengl)
#target_sources(affine PUBLIC
@@ -119,7 +112,6 @@ qt_add_resources(gradients "gradients"
#Qt::OpenGL
#)
#endif()
-# special case end
install(TARGETS gradients
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"