summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-20 13:41:37 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 15:25:39 +0000
commitaa50b377a7d904e35cf3a26e4c8a054108011ffd (patch)
treeff45946e5779357aa547f00a8b5b9d0119a2b8f2 /examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
parent05ebd62f099b51b160a06e1257007bf437355fae (diff)
CMake: Add widgets examples
Change-Id: Ib6142b93df066e3658eb189b50ca74c455fe7e56 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt b/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
new file mode 100644
index 0000000000..3c9082db07
--- /dev/null
+++ b/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
@@ -0,0 +1,33 @@
+# Generated from echowindow.pro.
+
+#####################################################################
+## echoplugin Binary:
+#####################################################################
+
+add_qt_executable(echoplugin
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/echoplugin"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/echoplugin"
+ SOURCES
+ echointerface.h
+ echowindow.cpp echowindow.h
+ main.cpp
+ LIBRARIES
+ Qt::Widgets
+)
+
+#### Keys ignored in scope 1:.:echowindow.pro:<NONE>:
+# CONFIG = "install_ok"
+# QMAKE_PROJECT_NAME = "echopluginwindow"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 3:.:echowindow.pro:CONFIG(debug,release OR debug):
+# DESTDIR = "../debug/"
+
+#### Keys ignored in scope 4:.:echowindow.pro:CONFIG(release,release OR debug):
+# DESTDIR = "../release/"
+
+#### Keys ignored in scope 5:.:echowindow.pro:else:
+# DESTDIR = "../"