summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/i18n/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/widgets/tools/i18n/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/tools/i18n/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/i18n/CMakeLists.txt55
1 files changed, 23 insertions, 32 deletions
diff --git a/examples/widgets/tools/i18n/CMakeLists.txt b/examples/widgets/tools/i18n/CMakeLists.txt
index 033362bb4c..3835cc27ea 100644
--- a/examples/widgets/tools/i18n/CMakeLists.txt
+++ b/examples/widgets/tools/i18n/CMakeLists.txt
@@ -1,38 +1,29 @@
# Generated from i18n.pro.
-#####################################################################
-## i18n Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(i18n LANGUAGES CXX)
-add_qt_executable(i18n
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/i18n"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/i18n"
- SOURCES
- languagechooser.cpp languagechooser.h
- main.cpp
- mainwindow.cpp mainwindow.h
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-# Resources:
-add_qt_resource(i18n "i18n" FILES
- translations/i18n_ar.qm
- translations/i18n_cs.qm
- translations/i18n_de.qm
- translations/i18n_el.qm
- translations/i18n_en.qm
- translations/i18n_eo.qm
- translations/i18n_fr.qm
- translations/i18n_it.qm
- translations/i18n_jp.qm
- translations/i18n_ko.qm
- translations/i18n_no.qm
- translations/i18n_ru.qm
- translations/i18n_sv.qm
- translations/i18n_zh.qm)
+find_package(Qt5 COMPONENTS Widgets)
+add_executable(i18n WIN32 MACOSX_BUNDLE
+ i18n.qrc
+ languagechooser.cpp languagechooser.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+)
+target_link_libraries(i18n PUBLIC
+ Qt::Widgets
+)
-#### Keys ignored in scope 1:.:i18n.pro:<NONE>:
-# TRANSLATIONS = "translations/i18n_ar.ts" "translations/i18n_cs.ts" "translations/i18n_de.ts" "translations/i18n_el.ts" "translations/i18n_en.ts" "translations/i18n_eo.ts" "translations/i18n_fr.ts" "translations/i18n_it.ts" "translations/i18n_jp.ts" "translations/i18n_ko.ts" "translations/i18n_no.ts" "translations/i18n_ru.ts" "translations/i18n_sv.ts" "translations/i18n_zh.ts"
+install(TARGETS i18n
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)