summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt30
1 files changed, 6 insertions, 24 deletions
diff --git a/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt b/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
index a0447c833e..31d6f5ef65 100644
--- a/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
+++ b/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
@@ -1,27 +1,9 @@
-# Generated from extrafilters.pro.
+# special case begin
-#####################################################################
-## qtLibraryTargetpnp_extrafilters Module:
-#####################################################################
-
-add_qt_plugin(pnp_extrafilters_plugin TYPE plugin # special case
- SOURCES
- extrafiltersplugin.cpp extrafiltersplugin.h
- INCLUDE_DIRECTORIES
- ../../app
- LIBRARIES
- Qt::Widgets
+add_library(pnp_extrafilters_plugin MODULE
+ extrafiltersplugin.cpp extrafiltersplugin.h
)
+target_include_directories(pnp_extrafilters_plugin PRIVATE ../../app)
+target_link_libraries(pnp_extrafilters_plugin PRIVATE Qt::Widgets)
-#### Keys ignored in scope 1:.:extrafilters.pro:<NONE>:
-# CONFIG = "plugin" "install_ok"
-# DESTDIR = "../../plugins"
-# INSTALLS = "target"
-# TEMPLATE = "lib"
-# target.path = "$$[QT_INSTALL_EXAMPLES]/widgets/tools/plugandpaint/plugins"
-
-## Scopes:
-#####################################################################
-
-#### Keys ignored in scope 2:.:extrafilters.pro:APPLE_UIKIT:
-# CONFIG = "debug_and_release"
+# special case end