summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt42
1 files changed, 19 insertions, 23 deletions
diff --git a/examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt b/examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt
index a6d6a56874..3e3893ad03 100644
--- a/examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt
+++ b/examples/widgets/tools/styleplugin/stylewindow/CMakeLists.txt
@@ -1,31 +1,27 @@
# Generated from stylewindow.pro.
-#####################################################################
-## styleplugin Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(styleplugin LANGUAGES CXX)
-add_qt_executable(styleplugin
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/styleplugin"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/styleplugin"
- SOURCES
- main.cpp
- stylewindow.cpp stylewindow.h
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#### Keys ignored in scope 1:.:stylewindow.pro:<NONE>:
-# CONFIG = "install_ok"
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-## Scopes:
-#####################################################################
+set(INSTALL_EXAMPLEDIR "examples")
-#### Keys ignored in scope 3:.:stylewindow.pro:debug:
-# DESTDIR = "../debug/"
+find_package(Qt5 COMPONENTS Widgets)
-#### Keys ignored in scope 4:.:stylewindow.pro:release:
-# DESTDIR = "../release/"
+add_executable(styleplugin WIN32 MACOSX_BUNDLE
+ main.cpp
+ stylewindow.cpp stylewindow.h
+)
+target_link_libraries(styleplugin PUBLIC
+ Qt::Widgets
+)
-#### Keys ignored in scope 5:.:stylewindow.pro:else:
-# DESTDIR = "../"
+install(TARGETS styleplugin
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)