summaryrefslogtreecommitdiffstats
path: root/examples/xml/htmlinfo/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-10 18:31:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-10 18:35:07 +0100
commit3af9d49bb78ac56bff57d1c3867853730f97a8e1 (patch)
treec9d6c1d1fe90dba3c788fd06795cf05a6d4ed5bb /examples/xml/htmlinfo/CMakeLists.txt
parent71436d5499a9e0355f778f47ef465486a727049d (diff)
parentc431e2d33c2b13dee8b43a08c267c20ec1ae9654 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Diffstat (limited to 'examples/xml/htmlinfo/CMakeLists.txt')
-rw-r--r--examples/xml/htmlinfo/CMakeLists.txt24
1 files changed, 21 insertions, 3 deletions
diff --git a/examples/xml/htmlinfo/CMakeLists.txt b/examples/xml/htmlinfo/CMakeLists.txt
index dde6e17fa0..77fa423eff 100644
--- a/examples/xml/htmlinfo/CMakeLists.txt
+++ b/examples/xml/htmlinfo/CMakeLists.txt
@@ -3,15 +3,15 @@
cmake_minimum_required(VERSION 3.14)
project(htmlinfo LANGUAGES CXX)
-find_package(Qt6 COMPONENTS Core) # special case: add
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/xml/htmlinfo")
+
+find_package(Qt6 COMPONENTS Core)
add_executable(htmlinfo
main.cpp
@@ -19,6 +19,24 @@ add_executable(htmlinfo
target_link_libraries(htmlinfo PUBLIC
Qt::Core
)
+
+
+# Resources:
+set(resources_resource_files
+ "apache_org.html"
+ "simpleexample.html"
+ "trolltech_com.html"
+ "w3c_org.html"
+ "youtube_com.html"
+)
+
+qt6_add_resources(htmlinfo "resources"
+ PREFIX
+ "/"
+ FILES
+ ${resources_resource_files}
+)
+
install(TARGETS htmlinfo
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"