summaryrefslogtreecommitdiffstats
path: root/examples/xml/htmlinfo/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 08:15:50 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 18:50:39 +0000
commit76108058796bf0884f6fd128d81f1bc49f9a56af (patch)
tree1c5f0740ca3217f3d11cf7c684143bbb0da0f336 /examples/xml/htmlinfo/CMakeLists.txt
parent465949420a877099247d94dd4db54d19ca5a9a7c (diff)
Regenerate examples
Change-Id: I04b2adbe370ffea81d7787ad90e4ae69d2c165cb Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/xml/htmlinfo/CMakeLists.txt')
-rw-r--r--examples/xml/htmlinfo/CMakeLists.txt24
1 files changed, 21 insertions, 3 deletions
diff --git a/examples/xml/htmlinfo/CMakeLists.txt b/examples/xml/htmlinfo/CMakeLists.txt
index dde6e17fa0..77fa423eff 100644
--- a/examples/xml/htmlinfo/CMakeLists.txt
+++ b/examples/xml/htmlinfo/CMakeLists.txt
@@ -3,15 +3,15 @@
cmake_minimum_required(VERSION 3.14)
project(htmlinfo LANGUAGES CXX)
-find_package(Qt6 COMPONENTS Core) # special case: add
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/xml/htmlinfo")
+
+find_package(Qt6 COMPONENTS Core)
add_executable(htmlinfo
main.cpp
@@ -19,6 +19,24 @@ add_executable(htmlinfo
target_link_libraries(htmlinfo PUBLIC
Qt::Core
)
+
+
+# Resources:
+set(resources_resource_files
+ "apache_org.html"
+ "simpleexample.html"
+ "trolltech_com.html"
+ "w3c_org.html"
+ "youtube_com.html"
+)
+
+qt6_add_resources(htmlinfo "resources"
+ PREFIX
+ "/"
+ FILES
+ ${resources_resource_files}
+)
+
install(TARGETS htmlinfo
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"