summaryrefslogtreecommitdiffstats
path: root/examples/xml/streambookmarks/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 16:22:32 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-27 12:49:39 +0100
commit397b3725176780d8888f8499cac0127dbb7df2c7 (patch)
treeb7c38898d1a7d2a2278b010b034b9c605c785c50 /examples/xml/streambookmarks/CMakeLists.txt
parent65fe5b2ce22797389aa074ef2c30e873a3c38d48 (diff)
CMake: Regenerate examples to set the WIN32_EXECUTABLE property
As well as the MACOSX_BUNDLE properties as necessary. Task-number: QTBUG-87664 Task-number: QTBUG-86827 Change-Id: I7677449a26d51fa853bd67bab6b3b61afbd2b12f Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/xml/streambookmarks/CMakeLists.txt')
-rw-r--r--examples/xml/streambookmarks/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/xml/streambookmarks/CMakeLists.txt b/examples/xml/streambookmarks/CMakeLists.txt
index 6a6de031e5..51393a2727 100644
--- a/examples/xml/streambookmarks/CMakeLists.txt
+++ b/examples/xml/streambookmarks/CMakeLists.txt
@@ -26,6 +26,10 @@ qt_add_executable(streambookmarks
xbelreader.cpp xbelreader.h
xbelwriter.cpp xbelwriter.h
)
+set_target_properties(streambookmarks PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(streambookmarks PUBLIC
Qt::Core
Qt::Gui