summaryrefslogtreecommitdiffstats
path: root/mkspecs/android-clang/qmake.conf
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-06-12 20:42:08 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2021-08-27 18:31:17 +0000
commit17d7a8dc2e2df577a769cd84cba946a726e8872a (patch)
tree77bf7c64c6e900948c9b49bfdbd0328ae305324a /mkspecs/android-clang/qmake.conf
parent1bdc35bfe05ac5385278d95a052ac51c1bc7bba6 (diff)
Update Android default SDK from 29 to 30
By the time of Qt 6.2 release all new apps targeting Play store must target API level 30 (Android 11) or above (starting in 08/2021 for new apps and 11/2021 for existing apps' updates). Pick-to: 6.2 5.15 Task-number: QTBUG-94451 Change-Id: Id7fa2fd62899a7259e365c917292c6c3ac0d2b0d Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io>
Diffstat (limited to 'mkspecs/android-clang/qmake.conf')
-rw-r--r--mkspecs/android-clang/qmake.conf2
1 files changed, 1 insertions, 1 deletions
diff --git a/mkspecs/android-clang/qmake.conf b/mkspecs/android-clang/qmake.conf
index 2ee64f3e2a..7f23b68f4d 100644
--- a/mkspecs/android-clang/qmake.conf
+++ b/mkspecs/android-clang/qmake.conf
@@ -44,7 +44,7 @@ isEmpty(ALL_ANDROID_ABIS): ALL_ANDROID_ABIS = arm64-v8a armeabi-v7a x86_64 x86
CONFIG += $$ANDROID_PLATFORM
ANDROID_MIN_SDK_VERSION = $$replace(ANDROID_PLATFORM, "android-", "")
-ANDROID_TARGET_SDK_VERSION = 29
+ANDROID_TARGET_SDK_VERSION = 30
NDK_LLVM_PATH = $$NDK_ROOT/toolchains/llvm/prebuilt/$$NDK_HOST
QMAKE_CC = $$NDK_LLVM_PATH/bin/clang