summaryrefslogtreecommitdiffstats
path: root/mkspecs/macx-clang-libc++/qmake.conf
diff options
context:
space:
mode:
authorMorten Johan Sorvig <morten.sorvig@nokia.com>2012-10-12 11:31:08 +0200
committerThe Qt Project <gerrit-noreply@qt-project.org>2012-10-24 01:39:45 +0200
commit9c6066fce6b2f96a336956214afb94a8592d2834 (patch)
tree0c7f01d76b1315fedc895e0fd0e67418fa272035 /mkspecs/macx-clang-libc++/qmake.conf
parent048d28a674cd1cbbc738a3045ae967323a9d41e9 (diff)
Mac: Set minimum version to 10.7 for clang-libc++
Clang's libc++ does not support 10.6. Add mac-minimum-version.conf which sets the version to 10.6. Set the version to 10.7 in the clang-libx++* mkspecs. Change-Id: I494d0d24b0d73d9395e9d5406c8c63c9af87f8cc Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@digia.com> Reviewed-by: Erik Verbruggen <erik.verbruggen@digia.com>
Diffstat (limited to 'mkspecs/macx-clang-libc++/qmake.conf')
-rw-r--r--mkspecs/macx-clang-libc++/qmake.conf1
1 files changed, 1 insertions, 0 deletions
diff --git a/mkspecs/macx-clang-libc++/qmake.conf b/mkspecs/macx-clang-libc++/qmake.conf
index e845147557..700959865e 100644
--- a/mkspecs/macx-clang-libc++/qmake.conf
+++ b/mkspecs/macx-clang-libc++/qmake.conf
@@ -10,6 +10,7 @@ include(../common/mac.conf)
include(../common/gcc-base-macx.conf)
include(../common/clang.conf)
include(../common/clang-mac.conf)
+include(../common/mac-clang-libc++-minimum-version.conf)
QMAKE_OBJECTIVE_CFLAGS += -stdlib=libc++
QMAKE_CXXFLAGS += -stdlib=libc++