summaryrefslogtreecommitdiffstats
path: root/qmake/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2019-12-02 11:10:05 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-01-06 11:53:53 +0000
commit4b2de41b13eb71c0ce841ef357768a3913b49810 (patch)
treeee088cae418eaf2c3b09f5af9c7de1d45d6eb17d /qmake/CMakeLists.txt
parent704ed86ed338a630970a507a4e7800e78102da06 (diff)
CMake: Add support for framework builds
Framework builds are enabled by default on macOS. They are controlled via the framework feature. Task-number: QTBUG-75751 Change-Id: I00bc64672f02bbd1672508b2b5010d202984a961 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'qmake/CMakeLists.txt')
-rw-r--r--qmake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/qmake/CMakeLists.txt b/qmake/CMakeLists.txt
index c58dd7adec..5f5f1f63c0 100644
--- a/qmake/CMakeLists.txt
+++ b/qmake/CMakeLists.txt
@@ -121,7 +121,7 @@ qt_add_tool(qmake # special case
generators/unix
generators/win32
library
- $<TARGET_PROPERTY:Qt::CorePrivate,INTERFACE_INCLUDE_DIRECTORIES> # special case
+ $<TARGET_PROPERTY:Qt::Core,INCLUDE_DIRECTORIES> # special case
${CMAKE_BINARY_DIR}/src/corelib/global # special case: for qconfig.cpp
PRECOMPILED_HEADER
"qmake_pch.h"