summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-02-02 11:51:59 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-02-09 09:17:21 +0100
commit9d84bafebabb48b83edd6392027238d7a4dd3581 (patch)
tree0e07fb62b137fe34d06f62a6ca083448a7e6c55a /src/CMakeLists.txt
parent841e63cb77094a7a50fe7c9f0e210b045f7c7402 (diff)
Make it possible to disable the PrintSupport module
Introduce the 'printsupport' feature to control whether the PrintSupport module is built. [ChangeLog][QtPrintSupport] Building of QtPrintSupport can be disabled by passing -no-feature-printsupport to configure. Fixes: QTBUG-90778 Change-Id: I8a9a4b7f8dd8f39a81565c8eb14ce1ae0839267d Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Nodir Temirkhodjaev <nodir.temir@gmail.com> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bf71322b44..62daf295e7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -67,7 +67,7 @@ endif()
if (QT_FEATURE_testlib)
add_subdirectory(testlib)
endif()
-if(QT_FEATURE_gui AND QT_FEATURE_widgets)
+if(QT_FEATURE_printsupport)
add_subdirectory(printsupport)
endif()
add_subdirectory(plugins)