summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-06-05 12:07:42 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-06-05 14:20:31 +0000
commit04da0df56851565fe93f69be72efbba2b492d5db (patch)
treefe0bc43e08e70b0d5dd798f02f48fc29341dab17 /src/CMakeLists.txt
parentbc9409d85748c7167a9e8e7eec82fa6c9420ea3d (diff)
Android: SDK Support
Enable building androiddeployqt when performing host builds only. Added QtPlatformAndroid.cmake to locate Java and the setup the android SDK platform when building on android. Install the androiddeployqt support files when performing a host build. Added ANDROID_SDK_ROOT configuration variable for specifying the android sdk directory. Generating the deployment-settings.json will be done in another change. Change-Id: I1bf15315af4ed904d2fb1d22b0e8e834df32d6ed Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3a3e358c73..682f70ebd2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,3 +56,5 @@ endif()
add_subdirectory(plugins)
add_subdirectory(winmain)
+
+add_subdirectory(android)