summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-02-12 10:02:15 +0100
committerKevin Funk <kevin.funk@kdab.com>2019-02-12 11:09:03 +0000
commit4bfd6c010bf37f1268a3da36fce2e20cf082157f (patch)
tree975d56cf5b8d4d4b8c40b524054642b658728d9b /src/CMakeLists.txt
parent61b5a32df3192c5ea44944e2002665af2e51dc21 (diff)
cmake: Create Qt5 compat targets in config files
For now create targets a la "Qt5::Core" to stay compatible with the current Qt5 naming scheme. The name is controllable via a CMake option. Change-Id: If43c058221949b1900c2093f39ccc9d0f38028f1 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f6720c99bd..551c27b0e7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -46,7 +46,7 @@ function(find_or_build_bootstrap_names)
find_or_build_bootstrap_tool(tracegen)
if (_build_tools)
- install(EXPORT "Qt${PROJECT_VERSION_MAJOR}ToolsTargets" NAMESPACE "Qt::" DESTINATION "${INSTALL_LIBDIR}/cmake/Qt${PROJECT_VERSION_MAJOR}")
+ install(EXPORT "Qt${PROJECT_VERSION_MAJOR}ToolsTargets" NAMESPACE "${QT_CMAKE_EXPORT_NAMESPACE}::" DESTINATION "${INSTALL_LIBDIR}/cmake/Qt${PROJECT_VERSION_MAJOR}")
endif()
endfunction()