summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2019-11-22 17:05:29 +0100
committerMårten Nordheim <marten.nordheim@qt.io>2019-11-22 18:03:20 +0000
commita640db0180f5217f8dc45687c27ea615ea013ca2 (patch)
tree526074ce460059c623988f3a32ae5c2433196738 /src/CMakeLists.txt
parent974536c4aae7766560a3251d82c3519fc78b3cd7 (diff)
Add parts needed for QtQuick3D
There is a patch in progress to add mappings for Qt3D, so reuse the old broken Qt3D mappings, delete the duplicates. QtOpenGLExtensions is needed, so this patch includes it. Change-Id: I27896ee88b9e6873c8cd52d86afc330e309e1e14 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 13a4e461ce..e7a8255029 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -33,6 +33,10 @@ endif()
if(QT_FEATURE_gui)
add_subdirectory(gui)
+ if(QT_FEATURE_opengl)
+ add_subdirectory(openglextensions)
+ endif()
+
if(QT_FEATURE_widgets)
add_subdirectory(widgets)
if(QT_FEATURE_opengl)