summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-10-15 17:04:27 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-10-17 12:13:00 +0200
commitb5af1408099dedd132f36e04d19cb5771a23ec28 (patch)
tree85109c13469dcde91aea87e29ed52c116732fbf8 /src/CMakeLists.txt
parent8ec4fd9cffe7977f6d7cb68ce38de4386a5795d6 (diff)
Generalize the winmain/qtmain entry-point library
The use-case is relevant for other platforms as well. Now that Qt has a module system we can also replace a lot of the hand crafted logic for linking with simpler constructs. Change-Id: Ib6853aaf81bfea79c31f2de741d65b4b56f23ef6 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 78ee63baae..aa4b1b06c4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -70,6 +70,6 @@ if(QT_FEATURE_gui AND QT_FEATURE_widgets)
endif()
add_subdirectory(plugins)
-add_subdirectory(winmain)
+add_subdirectory(entrypoint)
add_subdirectory(android)