summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2018-12-12 10:55:20 +0100
committerSimon Hausmann <simon.hausmann@qt.io>2018-12-14 14:04:59 +0000
commite57a94cbd8f28ccab8b3368afc4365237c533a4f (patch)
treeabfa6a25629580f6a76a0cf2d06cdeb593339b2b /src/CMakeLists.txt
parent07dfa3013c94ddfda692ac235b2e022f8265c450 (diff)
CMake: Use AUTOMOC/AUTOUIC/AUTORCC
Change-Id: I0235ca4f227623e5937348b4b010637921dbf154 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 16cb36e145..375b102f58 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,7 +23,6 @@ function(find_or_build_bootstrap_names)
endif()
endfunction()
- find_or_build_bootstrap_tool(qmocscanner)
if (_build_tools)
add_subdirectory(tools/bootstrap) # bootstrap library
endif()
@@ -32,10 +31,6 @@ function(find_or_build_bootstrap_names)
find_or_build_bootstrap_tool(qfloat16-tables)
find_or_build_bootstrap_tool(tracegen)
- # $<TARGET_FILE:Qt::qmocscanner> does not work during configure run, so export into a plain variable:
- get_target_property(_mocscanner "Qt::qmocscanner" IMPORTED_LOCATION)
- set(QT_MOCSCANNER "${_mocscanner}" CACHE INTERNAL "Qt moc scanner")
-
if (_build_tools)
install(EXPORT "Qt${PROJECT_VERSION_MAJOR}ToolsTargets" NAMESPACE "Qt::" DESTINATION "${INSTALL_LIBDIR}/cmake/Qt${PROJECT_VERSION_MAJOR}")
endif()
@@ -76,4 +71,5 @@ endif()
if (QT_FEATURE_testlib)
add_subdirectory(testlib)
endif()
+add_subdirectory(printsupport)
add_subdirectory(plugins)