summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing <johan.helsing@qt.io>2020-02-04 11:47:39 +0100
committerJohan Klokkhammer Helsing <johan.helsing@qt.io>2020-02-18 09:22:51 +0100
commit00eeed234f7c4cfc357b17424e0dcd714ff65e70 (patch)
tree19f93238e01638c519dbf6a15bd20768fab39aa6 /src/CMakeLists.txt
parent077959972b6eb6fab55d08f955e4eeade48c09a9 (diff)
Move QOpenGLWidget from QtOpenGL to its own module
Same pattern as QtQuickWidgets. Gets rid of QtOpenGL's dependency on QtWidgets. Task-number: QTBUG-74409 Change-Id: I4f9b55c23e25a1e0519734037b768a16e870c7d2 Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ea62fa8b34..ce94330a90 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -41,6 +41,9 @@ if(QT_FEATURE_gui)
if(QT_FEATURE_widgets)
add_subdirectory(widgets)
+ if(QT_FEATURE_opengl)
+ add_subdirectory(openglwidgets)
+ endif()
endif()
add_subdirectory(platformsupport)
add_subdirectory(platformheaders)