summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-01-14 11:35:53 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-01-17 16:16:55 +0000
commit6a1ee4de07cbaaeb0583b191fee6258e0a4003e4 (patch)
treee86409147fc72c1f714773baf810380b1aa33da8 /src/CMakeLists.txt
parent3ec578020c9e088c7356da07d9112ece37bbf496 (diff)
CMake: Store Qt features in CMake Cache
This is less self-contained than what we have, but significantly speeds up cmake configure/generate runs. This patch also warns when a feature is already defined. Change-Id: I8cab63e208ba98756b47d362a39b462f5ec55e20 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 375b102f58..503d7717fa 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -58,7 +58,6 @@ add_subdirectory(tools)
if(QT_FEATURE_gui)
add_subdirectory(gui)
- qt_pull_features_into_current_scope(PUBLIC_FEATURES Qt::Gui)
if(QT_FEATURE_widgets)
add_subdirectory(widgets)
if(QT_FEATURE_opengl)