summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-08-17 10:44:14 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-08-17 18:19:22 +0200
commita930e657edbc4dcd1437f3f4146a4e46e0ce2d62 (patch)
treec1fb5e158358bfdd8bc7011df6a54e1da212b53c /src/corelib/CMakeLists.txt
parent96dd73c5fecd24dd3ab023c51d0051e28f3bde72 (diff)
CMake: Fix what Android plugin suffix should be passed as a define
CMAKE_SYSTEM_PROCESSOR has the value i686 when targeting the x86 Android ABI, which is set by the Android CMake toolchain. This is not the value that Qt expects, and potentially breaks loading of Qt plugins. The same with aarch64 instead of arm64-v8a. In qmake the proper values for QT_ARCH variable are the equivalent of the ANDROID_ABI variable set by the CMake toolchain file, so use ANDROID_ABI. Task-number: QTBUG-85399 Change-Id: Ia2eaceb75168cddb2d28414f1f4bf481ec76f29e Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 6f78e2bdc6..eef80acd2a 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -436,7 +436,7 @@ qt_extend_target(Core CONDITION ANDROID
kernel/qsharedmemory_android.cpp
kernel/qsystemsemaphore_android.cpp
DEFINES
- LIBS_SUFFIX="_${CMAKE_SYSTEM_PROCESSOR}.so"
+ LIBS_SUFFIX="_${ANDROID_ABI}.so" # special case
)
qt_extend_target(Core CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i386")