summaryrefslogtreecommitdiffstats
path: root/src/entrypoint/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-10-21 17:32:05 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-10-23 20:08:07 +0200
commit85ba43061f48bd7d11abc31b5315224d9fe926db (patch)
tree20dd8cd80b6d3c5252861cca425d6c001e98fa7a /src/entrypoint/CMakeLists.txt
parent83ad2377714383710193798bd453f9b8e881e05b (diff)
Make entry point module an internal module
Change-Id: I9eaadc7ce8ca03d64ff3a33c7b6641b073570a61 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/entrypoint/CMakeLists.txt')
-rw-r--r--src/entrypoint/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/entrypoint/CMakeLists.txt b/src/entrypoint/CMakeLists.txt
index 16c01540dd..fc04dac6df 100644
--- a/src/entrypoint/CMakeLists.txt
+++ b/src/entrypoint/CMakeLists.txt
@@ -6,8 +6,10 @@ endif()
qt_internal_add_module(EntryPoint
STATIC
+ INTERNAL_MODULE
NO_SYNC_QT
NO_MODULE_HEADERS
+ NO_PRIVATE_MODULE
DEFINES
QT_NO_FOREACH
INCLUDE_DIRECTORIES