summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-09-22 11:58:11 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-09-25 08:59:26 +0200
commit3bbe97b4444e3e064c55dae1998ee34e6c71cf4d (patch)
tree545c6f15b7b1128c76a111f82a23ec97ddcde713 /src/gui/CMakeLists.txt
parent6b8ee60d8ab6b473c091e8241f920824db9afcdc (diff)
CMake: Expose XKB::XKB as public dependency of Qt::GuiPrivate
Headers of xkbcommon are used in private headers, and consumers of Qt::GuiPrivate should automatically link against XKB::XKB. Change-Id: I99c67b5f291f64b529aed1499a00a215b5db3be2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 29ae78aa04..e4849939fc 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -1001,6 +1001,10 @@ qt_internal_extend_target(Gui CONDITION QT_FEATURE_xkbcommon AND UNIX
platform/unix/qxkbcommon_3rdparty.cpp
LIBRARIES
XKB::XKB
+# special case begin
+ PRIVATE_MODULE_INTERFACE
+ XKB::XKB
+# special case end
)
qt_internal_extend_target(Gui CONDITION IOS OR MACOS