summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-09-07 17:28:00 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-09-11 00:41:13 +0200
commit69004cb2900dcfc530e1e2efb783f559661a8a50 (patch)
tree34a177a1ab5df628745380d7721dbe57d487cb89 /src/gui/CMakeLists.txt
parent0f4422113cec41f2f3544c03b91d8d6220dff360 (diff)
Do not expose xlib as public dependency of QtGui
Consumers of QtGui should link explicitly to xlib if needed. Fixes: QTBUG-86421 Change-Id: Ibc94eb1c1ac405b53749b320c388b037bf693a08 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 1804991a7a..dc7d28d0f1 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -820,7 +820,7 @@ qt_extend_target(Gui CONDITION QT_FEATURE_undogroup
qt_extend_target(Gui CONDITION QT_FEATURE_opengl AND QT_FEATURE_xlib AND NOT QT_FEATURE_opengles2
SOURCES
opengl/platform/unix/qglxconvenience.cpp opengl/platform/unix/qglxconvenience_p.h
- PUBLIC_LIBRARIES
+ LIBRARIES
X11::X11
)