summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2020-08-20 14:54:39 +0200
committerEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2020-08-24 07:08:45 +0200
commitf70b955ce8fcb9d034bc46ccc3d1c9cc675a2f98 (patch)
tree265cd2a060921b0897059b0c228386a89c52674b /src/gui/CMakeLists.txt
parent75097c77822f38dfed883da7e6c30d108fb5b1ea (diff)
Remove the QPF2 font engine
The QPF2 font engine has been kept around for compatibility reasons in Qt 5.x, and it is time for it to retire for now. If we want something like this in the future, we can revive it with hardware acceleration / Qt Quick as one of the primary use cases, but for now, it seems that Freetype and our existing caching is sufficient also for low-end use cases. [ChangeLog][QtGui][Text] Removed support for the legacy QPF2 font format as well as the makeqpf tool used to generate those files. Change-Id: Id43039c92fe5bd95b628cd769e045c029f39a350 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 1f809a827c..d125d0dc0c 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -217,7 +217,6 @@ qt_add_module(Gui
text/qfont.cpp text/qfont.h text/qfont_p.h
text/qfontdatabase.cpp text/qfontdatabase.h text/qfontdatabase_p.h
text/qfontengine.cpp text/qfontengine_p.h
- text/qfontengine_qpf2.cpp
text/qfontengineglyphcache.cpp text/qfontengineglyphcache_p.h
text/qfontinfo.h
text/qfontmetrics.cpp text/qfontmetrics.h