summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Shaw <andy.shaw@qt.io>2020-12-04 15:04:49 +0100
committerAndy Shaw <andy.shaw@qt.io>2021-01-20 12:29:38 +0100
commit15576c961047231a49afda9b9ee0159ba132c0ae (patch)
treed2ff922cd5a3f910471d69380ea12ce99155a212 /src/gui/CMakeLists.txt
parenta5bb7b3ca510c301baf84e1dd46d5aeeb4986eb2 (diff)
iOS: Handle keyboard events when using an external keyboard
This enables the two possible approaches for handling external keyboard events. While support still exists for before 13.4 then both approaches are needed. This ensures that all external keyboard events are handled as key events and passed on accordingly. Additionally, this accounts for possible shortcuts too, therefore a new function is added to QShortcutMap to aid that. As a result, code has now moved from QCocoaKeyMapper to be part of the gui/platforms/darwin part to make it easier to reuse this code elsewhere. Fixes: QTBUG-85727 Change-Id: I349af43468b03fd8dcb16adba02669974affe154 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 979de8aadf..40c373c6d9 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -359,6 +359,7 @@ qt_internal_extend_target(Gui CONDITION MACOS
platform/macos/qcocoanativeinterface.mm
LIBRARIES
${FWAppKit}
+ ${FWCarbon}
PUBLIC_LIBRARIES
${FWAppKit}
)
@@ -369,6 +370,7 @@ qt_internal_extend_target(Gui CONDITION APPLE
painting/qcoregraphics.mm painting/qcoregraphics_p.h
painting/qrasterbackingstore.cpp painting/qrasterbackingstore_p.h
platform/darwin/qmacmime.mm platform/darwin/qmacmime_p.h
+ platform/darwin/qapplekeymapper.mm platform/darwin/qapplekeymapper_p.h
text/coretext/qcoretextfontdatabase.mm text/coretext/qcoretextfontdatabase_p.h
text/coretext/qfontengine_coretext.mm text/coretext/qfontengine_coretext_p.h
LIBRARIES