summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-04-09 13:23:42 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-08-05 09:17:11 +0200
commit07b008425acb1f550c3e6e96e2bd6033fe86976a (patch)
tree19d1f4552f2766418b002dd51e7c22cf958aee9d /src/network/CMakeLists.txt
parentc8db3115a212de3c2ef01f20891ef6545f2f3850 (diff)
Privately introducing QDecompressHelper for network purposes
To support streaming decompression in QNAM. Will also be used to refactor existing decompression code in QNAM. Task-number: QTBUG-83269 Change-Id: Iecf3e359734163f15686c949f75d41fa4794a00e Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 680b14c546..c421622a44 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -100,6 +100,7 @@ qt_extend_target(Network CONDITION WASM
qt_extend_target(Network CONDITION QT_FEATURE_http
SOURCES
+ access/qdecompresshelper.cpp access/qdecompresshelper_p.h
access/http2/bitstreams.cpp access/http2/bitstreams_p.h
access/http2/hpack.cpp access/http2/hpack_p.h
access/http2/hpacktable.cpp access/http2/hpacktable_p.h