summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorTimur Pocheptsov <timur.pocheptsov@qt.io>2021-02-25 11:30:21 +0100
committerTimur Pocheptsov <timur.pocheptsov@qt.io>2021-03-04 07:04:45 +0100
commit6c835796c8ea2590008900ffb5f4bf0d902ee73d (patch)
treec47d4ad51483ceff896961f2eb850930af41c34e /src/network/CMakeLists.txt
parentdcbaf539eafd6e8190cab29744ab6483993f4fd0 (diff)
Convert QDtls classes to the new plugin-based design
Essentially, the same code re-shuffled and placed behind the new interfaces. Pick-to: dev Fixes: QTBUG-91174 Task-number: QTBUG-65922 Change-Id: I8f14697f10713f9738c5c7805aed0150c084850c Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 1d0e32cc19..636eb2d3da 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -357,6 +357,7 @@ qt_internal_extend_target(Network CONDITION QT_FEATURE_securetransport AND QT_FE
qt_internal_extend_target(Network CONDITION QT_FEATURE_dtls AND QT_FEATURE_ssl
SOURCES
ssl/qdtls.cpp ssl/qdtls.h ssl/qdtls_p.h
+ ssl/qdtls_base.cpp ssl/qdtls_base_p.h
)
qt_internal_extend_target(Network CONDITION QT_FEATURE_openssl AND QT_FEATURE_ssl