summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-08-20 12:03:54 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-08-27 18:58:21 +0200
commitf7f79483e73fed5664763a125b3d27861586b7d2 (patch)
tree13910131de10d3d8d6d240b4cfd05309de8343c8 /src/network/CMakeLists.txt
parent3964ece5a566d1ed517406f0ff713f6f184628ae (diff)
Remove QFtp sources etc. in favor of alternate distribution
While we initially wanted to just disable the functionality the way it is currently built forces people to do a full build of Qt just to enable it. Instead of doing this half-measure let's just remove the code completely from QtBase and rather prepare QtNetwork to handle being a plugin that can be compiled at any time. Task-number: QTBUG-80340 Change-Id: I19155c8c167cf932088f01b2a9706d0e7ab792d1 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index b42a4fc117..e54582c299 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -70,13 +70,6 @@ qt_extend_target(Network CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i3
"/BASE:0x64000000"
)
-qt_extend_target(Network CONDITION QT_FEATURE_ftp
- SOURCES
- access/qftp.cpp access/qftp_p.h
- access/qnetworkaccessftpbackend.cpp access/qnetworkaccessftpbackend_p.h
- kernel/qurlinfo.cpp kernel/qurlinfo_p.h
-)
-
qt_extend_target(Network CONDITION QT_FEATURE_networkdiskcache
SOURCES
access/qnetworkdiskcache.cpp access/qnetworkdiskcache.h access/qnetworkdiskcache_p.h