summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-04 15:13:46 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-06 10:49:00 +0000
commitf26a156dd3e7784b0345789c5c85ad397ffb4ad2 (patch)
tree6daf33625795af60b78a45b4a441756cc746b956 /src/network/CMakeLists.txt
parent380f1eb92fccc865cdd00d74f2e160a358829ee4 (diff)
Fix special cases in network
Change-Id: I66cc33afe3bfdf4e86dfeb0b341770355f59c0da Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 380ed8e946..3ce9a3aa0a 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -152,11 +152,13 @@ extend_target(Network CONDITION UNIX
${CMAKE_DL_LIBS}
)
-# special case: Do not add this to android!
+# special case begin
+# Do not add this to android!
extend_target(Network CONDITION QT_FEATURE_dnslookup AND UNIX AND NOT INTEGRITY AND NOT ANDROID
SOURCES
kernel/qdnslookup_unix.cpp
)
+# special case end
extend_target(Network CONDITION QT_FEATURE_linux_netlink AND UNIX
SOURCES