summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/input/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-07-03 08:32:08 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-07-04 20:46:07 +0200
commit864466d2e5ae9ab7a2e01a7da3abc5a4c0b16bda (patch)
treef1c09a2320f2455d3f2c81a9e91031f4a8b9d849 /src/platformsupport/input/CMakeLists.txt
parent90f1ef14aaf2f4b4dc49755ab8605e6a37ee06c6 (diff)
Move xkbcommon to QtGui
Task-number: QTBUG-83255 Change-Id: Ia1c6a49af6be4aaa6b988537c38db3a2c0a646a5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/platformsupport/input/CMakeLists.txt')
-rw-r--r--src/platformsupport/input/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/src/platformsupport/input/CMakeLists.txt b/src/platformsupport/input/CMakeLists.txt
index 7ab93df062..2c2a9fa1cc 100644
--- a/src/platformsupport/input/CMakeLists.txt
+++ b/src/platformsupport/input/CMakeLists.txt
@@ -22,7 +22,7 @@ qt_add_module(InputSupport
"../../corelib/global/qt_pch.h"
)
-#### Keys ignored in scope 3:.:.:input-support.pro:<TRUE>:
+#### Keys ignored in scope 2:.:.:input-support.pro:<TRUE>:
# MODULE = "input_support"
## Scopes:
@@ -82,13 +82,6 @@ qt_extend_target(InputSupport CONDITION QT_FEATURE_libinput
PkgConfig::Libudev
)
-qt_extend_target(InputSupport CONDITION QT_FEATURE_libinput AND QT_FEATURE_xkbcommon
- LIBRARIES
- XKB::XKB
- PUBLIC_LIBRARIES
- Qt::XkbCommonSupportPrivate
-)
-
qt_extend_target(InputSupport CONDITION QT_FEATURE_evdev OR QT_FEATURE_libinput
SOURCES
shared/devicehandlerlist_p.h
@@ -102,6 +95,3 @@ qt_extend_target(InputSupport CONDITION QT_FEATURE_integrityhid
LIBRARIES
integrityhid
)
-if(QT_FEATURE_xkbcommon)
- add_subdirectory(xkbcommon)
-endif()