summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/jpeg/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2022-04-27 20:21:27 +0200
committerMarc Mutz <marc.mutz@qt.io>2022-04-28 11:15:03 +0200
commit1ca7b516944546e2de2b06dc7698338140f7e4ec (patch)
tree916bcecdf80dd36a57f44852848f07afaf307d66 /src/plugins/imageformats/jpeg/CMakeLists.txt
parent7d4b480be360d3d25f059c6edbef7d2e7f74da8f (diff)
Image Plugins: includemocs(-ish)
Including moc files directly into their classes' TU tends to improve codegen and enables extended compiler warnings, e.g. about unused private functions or fields. The result of the automated script is no good here, because these plugins all use the same anti-pattern of defining the plugin class in a header, main.h, which doesn't have include guards. Included moc files therefore lead to redefiniton errors. Fix by inlining the main.h's into the respective main.cpp's and including main.moc's instead. Task-number: QTBUG-102886 Pick-to: 6.3 6.2 5.15 Change-Id: I6d3ec5590d13d9b7a4cedd5f1b4d3331e6916655 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'src/plugins/imageformats/jpeg/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/jpeg/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/imageformats/jpeg/CMakeLists.txt b/src/plugins/imageformats/jpeg/CMakeLists.txt
index 3dfd8982c3..bb5a78fa40 100644
--- a/src/plugins/imageformats/jpeg/CMakeLists.txt
+++ b/src/plugins/imageformats/jpeg/CMakeLists.txt
@@ -10,7 +10,7 @@ qt_internal_add_plugin(QJpegPlugin
OUTPUT_NAME qjpeg
PLUGIN_TYPE imageformats
SOURCES
- main.cpp main.h
+ main.cpp
qjpeghandler.cpp qjpeghandler_p.h
LIBRARIES
Qt::Core