summaryrefslogtreecommitdiffstats
path: root/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorMÃ¥rten Nordheim <marten.nordheim@qt.io>2022-11-03 13:40:18 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-11-08 10:27:25 +0000
commit905755304a474c942346774d930b92e3665c1bab (patch)
treef83e2542aa57f34760ad3cdc694765713c52fe38 /src/plugins/networkinformation/networklistmanager/CMakeLists.txt
parent58482c63f090dbfdf0c6ad8ee317b24fbefe798e (diff)
QNetworkInformation[Win]: Catch potential exceptionsv6.4.16.4.1
Some Windows SDKs seem to throw an exception (sometimes?) when calling ConnectionProfile::NetworkAdapter. Catch the exception and ignore it, we would return Unknown anyway. And just in case it is needed, do the same for GetConnectionCost. This requires enabling exceptions for the plugin. Fixes: QTBUG-108156 Change-Id: Ie6c5adb3715578aa94ef3391afae79d9aecdc5d3 Reviewed-by: Oliver Wolff <oliver.wolff@qt.io> (cherry picked from commit 35e54f9b7bba9ad7b1757e0b8f7d03859a694b34) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'src/plugins/networkinformation/networklistmanager/CMakeLists.txt')
-rw-r--r--src/plugins/networkinformation/networklistmanager/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/networkinformation/networklistmanager/CMakeLists.txt b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
index d927d4af60..2fb65377d4 100644
--- a/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
+++ b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
@@ -3,6 +3,7 @@ qt_internal_add_plugin(QNLMNIPlugin
CLASS_NAME QNetworkListManagerNetworkInformationBackendFactory
PLUGIN_TYPE networkinformation
DEFAULT_IF WIN32 AND QT_FEATURE_networklistmanager
+ EXCEPTIONS
SOURCES
qnetworklistmanagernetworkinformationbackend.cpp
qnetworklistmanagerevents.h qnetworklistmanagerevents.cpp