summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
authorThe Qt Project <gerrit-noreply@qt-project.org>2020-02-12 08:47:47 +0000
committerThe Qt Project <gerrit-noreply@qt-project.org>2020-02-12 08:47:47 +0000
commitf4a52b79ced0726b207c1af8c12ada1f8be12ff0 (patch)
treed11ec8434ee3c61ddc1f0d04009cfc478ec05af5 /src/plugins/platforms/cocoa/CMakeLists.txt
parent99da0c164b02dca8f556c3186231e6b0723c532c (diff)
parentc53f8c038c0736aeb208bcd69bf3b5e2816c29ae (diff)
Merge "Merge remote-tracking branch 'origin/dev' into wip/cmake" into wip/cmake
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index 27b646d293..9e8b162aec 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -111,6 +111,11 @@ qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_sessionmanager
qcocoasessionmanager.cpp qcocoasessionmanager.h
)
+qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::PlatformCompositorSupportPrivate
+ PUBLIC_LIBRARIES
+ Qt::PlatformCompositorSupportPrivate
+)
+
qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::Widgets
SOURCES
qpaintengine_mac.mm qpaintengine_mac_p.h
@@ -118,7 +123,7 @@ qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::Widgets
Qt::WidgetsPrivate
)
-#### Keys ignored in scope 7:.:.:cocoa.pro:TARGET Qt::Widgets:
+#### Keys ignored in scope 8:.:.:cocoa.pro:TARGET Qt::Widgets:
# QT_FOR_CONFIG = "widgets"
qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
@@ -145,5 +150,5 @@ qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_fontdialog AND TAR
qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
)
-#### Keys ignored in scope 12:.:.:cocoa.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 13:.:.:cocoa.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"