summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-01-22 14:23:02 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-01-27 11:49:34 +0000
commitb10d8eab047c387409716ae87422d2efffee3159 (patch)
treef5ce14f553e5b8de3b2ebda30965ce4f5df380d6 /src/plugins/platforms/cocoa/CMakeLists.txt
parent604aa83ad910c3a17af33850312d3c61a59f558f (diff)
Regenerate plugin projects to get new target names
And also to get the original output names (qmake's "TARGET"), so that the plugin file names are as they were in Qt 5. Change-Id: I96a060d1a81693652847857372bec334728cb549 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt28
1 files changed, 14 insertions, 14 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index dbaea562a8..7ed2a8ffdb 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -4,13 +4,13 @@
qt_find_package(Cups PROVIDED_TARGETS Cups::Cups)
#####################################################################
-## qcocoa Plugin:
+## QCocoaIntegrationPlugin Plugin:
#####################################################################
-qt_add_plugin(qcocoa
- TYPE platforms
+qt_add_plugin(QCocoaIntegrationPlugin
+ OUTPUT_NAME qcocoa
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES cocoa # special case
- CLASS_NAME QCocoaIntegrationPlugin
+ TYPE platforms
SOURCES
main.mm
messages.cpp messages.h
@@ -77,7 +77,7 @@ set(qcocoaresources_resource_files
"images/waitcursor.png"
)
-qt_add_resource(qcocoa "qcocoaresources"
+qt_add_resource(QCocoaIntegrationPlugin "qcocoaresources"
PREFIX
"/qt-project.org/mac/cursors"
FILES
@@ -91,12 +91,12 @@ qt_add_resource(qcocoa "qcocoaresources"
## Scopes:
#####################################################################
-qt_extend_target(qcocoa CONDITION QT_FEATURE_opengl
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_opengl
SOURCES
qcocoaglcontext.h qcocoaglcontext.mm
)
-qt_extend_target(qcocoa CONDITION QT_FEATURE_vulkan
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_vulkan
SOURCES
qcocoavulkaninstance.h qcocoavulkaninstance.mm
LIBRARIES
@@ -105,7 +105,7 @@ qt_extend_target(qcocoa CONDITION QT_FEATURE_vulkan
Qt::VulkanSupport
)
-qt_extend_target(qcocoa CONDITION QT_FEATURE_accessibility
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_accessibility
SOURCES
qcocoaaccessibility.h qcocoaaccessibility.mm
qcocoaaccessibilityelement.h qcocoaaccessibilityelement.mm
@@ -115,12 +115,12 @@ qt_extend_target(qcocoa CONDITION QT_FEATURE_accessibility
Qt::AccessibilitySupport
)
-qt_extend_target(qcocoa CONDITION QT_FEATURE_sessionmanager
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_sessionmanager
SOURCES
qcocoasessionmanager.cpp qcocoasessionmanager.h
)
-qt_extend_target(qcocoa CONDITION TARGET Qt::Widgets
+qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::Widgets
SOURCES
qpaintengine_mac.mm qpaintengine_mac_p.h
LIBRARIES
@@ -132,7 +132,7 @@ qt_extend_target(qcocoa CONDITION TARGET Qt::Widgets
#### Keys ignored in scope 7:.:.:cocoa.pro:TARGET Qt::Widgets:
# QT_FOR_CONFIG = "widgets"
-qt_extend_target(qcocoa CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
+qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
SOURCES
qcocoaprintdevice.h qcocoaprintdevice.mm
qcocoaprintersupport.h qcocoaprintersupport.mm
@@ -143,17 +143,17 @@ qt_extend_target(qcocoa CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
Qt::PrintSupport
)
-qt_extend_target(qcocoa CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
SOURCES
qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
)
-qt_extend_target(qcocoa CONDITION QT_FEATURE_filedialog AND TARGET Qt::Widgets
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_filedialog AND TARGET Qt::Widgets
SOURCES
qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
)
-qt_extend_target(qcocoa CONDITION QT_FEATURE_fontdialog AND TARGET Qt::Widgets
+qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_fontdialog AND TARGET Qt::Widgets
SOURCES
qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
)