summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-04-02 13:46:58 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-04-03 08:54:51 +0000
commit9a7de16fac8d4f2bcbc635db4a83ac78380287fc (patch)
tree2d31c86e279df2514ec8df1dc538b57212412cf4 /src/plugins/platforms/eglfs/CMakeLists.txt
parent11f217d21b7b5848e13bb0091855d50fbcbda3ce (diff)
CMake: Re-generate plugins/platforms/eglfs
Change-Id: I62651eac0eede77f1b7fa86e198f71b0ea1da2c7 Reviewed-by: Albert Astals Cid <albert.astals.cid@kdab.com>
Diffstat (limited to 'src/plugins/platforms/eglfs/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/CMakeLists.txt75
1 files changed, 34 insertions, 41 deletions
diff --git a/src/plugins/platforms/eglfs/CMakeLists.txt b/src/plugins/platforms/eglfs/CMakeLists.txt
index e508745da8..5a4639ddd3 100644
--- a/src/plugins/platforms/eglfs/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from eglfs.pro.
-
find_package(EGL)
find_package(WrapOpenGL)
@@ -23,21 +21,23 @@ add_qt_module(EglFSDeviceIntegration
api
LIBRARIES
Qt::CorePrivate
- Qt::GuiPrivate
Qt::DeviceDiscoverySupportPrivate
+ Qt::EglSupportPrivate
Qt::EventDispatcherSupportPrivate
+ Qt::FbSupportPrivate
+ Qt::FontDatabaseSupportPrivate
+ Qt::GuiPrivate
Qt::ServiceSupportPrivate
Qt::ThemeSupportPrivate
- Qt::FontDatabaseSupportPrivate
- Qt::FbSupportPrivate
- Qt::EglSupportPrivate
- EGL::EGL
- WrapOpenGL
- # CONFIG = "internal_module" "egl"
- # MODULE = "eglfsdeviceintegration"
- # _LOADED = "qt_module"
+ EGL::EGL # special case
+ WrapOpenGL # special case
)
+#### Keys ignored in scope 2:.:./eglfsdeviceintegration.pro:<NONE>:
+# CONFIG = "internal_module" "egl"
+# MODULE = "eglfsdeviceintegration"
+# _LOADED = "qt_module"
+
## Scopes:
#####################################################################
@@ -51,26 +51,18 @@ extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::PlatformCompositorSupp
Qt::PlatformCompositorSupportPrivate
)
-# TODO
-# extend_target(EglFSDeviceIntegration CONDITION NOT EGLFS_PLATFORM_HOOKS_SOURCES_ISEMPTY
-# DEFINES
-# EGLFS_PLATFORM_HOOKS
-# )
-
-# TODO
-# extend_target(EglFSDeviceIntegration CONDITION NOT EGLFS_DEVICE_INTEGRATION_ISEMPTY
-# DEFINES
-# EGLFS_PREFERRED_PLUGIN=
-# )
-#
-#extend_target(EglFSDeviceIntegration CONDITION use_gold_linker
-# # CONFIG = "no_linker_version_script"
-#)
-
-extend_target(EglFSDeviceIntegration CONDITION NOT DEFINES___contains___QT_NO_CURSOR
- SOURCES
- cursor.qrc
-)
+# special case:
+# extend_target(EglFSDeviceIntegration CONDITION NOT EGLFS_PLATFORM_HOOKS_SOURCES_ISEMPTY ...
+# extend_target(EglFSDeviceIntegration CONDITION NOT EGLFS_DEVICE_INTEGRATION_ISEMPTY ...
+
+#### Keys ignored in scope 7:.:./eglfsdeviceintegration.pro:use_gold_linker:
+# CONFIG = "no_linker_version_script"
+
+# Resources:
+add_qt_resource(EglFSDeviceIntegration "cursor" FILES
+ cursor-atlas.png
+ cursor.json)
+
extend_target(EglFSDeviceIntegration CONDITION QT_FEATURE_opengl
SOURCES
@@ -90,20 +82,21 @@ add_qt_plugin(qeglfs
INCLUDE_DIRECTORIES
api
LIBRARIES
- Qt::CorePrivate
+ Qt::CorePrivate # special case
Qt::EglFSDeviceIntegrationPrivate
- EGL::EGL
- # CONFIG = "egl"
- # OTHER_FILES = "$$PWD/eglfs.json"
- # PLUGIN_CLASS_NAME = "QEglFSIntegrationPlugin"
- # _LOADED = "qt_plugin"
+ EGL::EGL # special case
)
+#### Keys ignored in scope 11:.:./eglfs-plugin.pro:<NONE>:
+# CONFIG = "egl"
+# OTHER_FILES = "$$PWD/eglfs.json"
+# PLUGIN_CLASS_NAME = "QEglFSIntegrationPlugin"
+# _LOADED = "qt_plugin"
+
## Scopes:
#####################################################################
-#
-#extend_target(qeglfs CONDITION NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN
-# # PLUGIN_EXTENDS = "-"
-#)
+#### Keys ignored in scope 12:.:./eglfs-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+# PLUGIN_EXTENDS = "-"
add_subdirectory(deviceintegration)
+