summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/windows/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-03 19:44:27 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-05 14:36:31 +0000
commitac38fa11823f4cf020a9481c9de3d61caa8fccdc (patch)
treec7a07940738e7015cb43e28f97b9f2bde794b039 /src/plugins/platforms/windows/CMakeLists.txt
parentc5b61d2e90fde5d9f2e968f4443ca393e52393f5 (diff)
Regenerate projects to correctly handle private dependencies
Change-Id: I7d84bc9962bff5c89a90367ae704974c6ce2ec89 Reviewed-by: Qt CMake Build Bot Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/windows/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/windows/CMakeLists.txt25
1 files changed, 8 insertions, 17 deletions
diff --git a/src/plugins/platforms/windows/CMakeLists.txt b/src/plugins/platforms/windows/CMakeLists.txt
index 1c017ed2e5..0481246384 100644
--- a/src/plugins/platforms/windows/CMakeLists.txt
+++ b/src/plugins/platforms/windows/CMakeLists.txt
@@ -42,11 +42,6 @@ qt_add_plugin(QWindowsIntegrationPlugin
INCLUDE_DIRECTORIES
${CMAKE_CURRENT_SOURCE_DIR}
LIBRARIES
- Qt::CorePrivate
- Qt::EventDispatcherSupportPrivate
- Qt::FontDatabaseSupportPrivate
- Qt::GuiPrivate
- Qt::ThemeSupportPrivate
advapi32
d3d9
gdi32
@@ -56,10 +51,12 @@ qt_add_plugin(QWindowsIntegrationPlugin
winmm
PUBLIC_LIBRARIES
Qt::Core
- Qt::EventDispatcherSupport
- Qt::FontDatabaseSupport
+ Qt::CorePrivate
+ Qt::EventDispatcherSupportPrivate
+ Qt::FontDatabaseSupportPrivate
Qt::Gui
- Qt::ThemeSupport
+ Qt::GuiPrivate
+ Qt::ThemeSupportPrivate
dwmapi
imm32
oleaut32
@@ -110,19 +107,15 @@ qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_accessibility
uiautomation/qwindowsuiautils.cpp uiautomation/qwindowsuiautils.h
uiautomation/qwindowsuiavalueprovider.cpp uiautomation/qwindowsuiavalueprovider.h
uiautomation/qwindowsuiawindowprovider.cpp uiautomation/qwindowsuiawindowprovider.h
- LIBRARIES
- Qt::AccessibilitySupportPrivate
PUBLIC_LIBRARIES
- Qt::AccessibilitySupport
+ Qt::AccessibilitySupportPrivate
)
qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_vulkan
SOURCES
qwindowsvulkaninstance.cpp qwindowsvulkaninstance.h
- LIBRARIES
- Qt::VulkanSupportPrivate
PUBLIC_LIBRARIES
- Qt::VulkanSupport
+ Qt::VulkanSupportPrivate
)
#### Keys ignored in scope 4:.:.:windows.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
@@ -220,10 +213,8 @@ if(QT_FEATURE_imageformat_png)
endif()
qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_accessibility AND TARGET Qt::WindowsUIAutomationSupportPrivate
- LIBRARIES
- Qt::WindowsUIAutomationSupportPrivate
PUBLIC_LIBRARIES
- Qt::WindowsUIAutomationSupport
+ Qt::WindowsUIAutomationSupportPrivate
)
qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_accessibility AND mingw