summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
authorLiang Qi <liang.qi@qt.io>2019-05-02 14:09:25 +0200
committerLiang Qi <liang.qi@qt.io>2019-05-02 13:29:16 +0000
commit67c35ed8fc19130ba449099c02bede64b763c59f (patch)
tree533fd4e0bb89f2d3b0b94ae8c29f024002ea2bd6 /src/plugins/platforms/xcb/CMakeLists.txt
parent1b36fe53c621a4f37322c1bca755989d76b7d3cf (diff)
CMake: add xcb platform plugin
Change-Id: I9b3e8b5e4a2f7799b32738319e6eed912d3261e2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 413599e6c5..f67c48c1d2 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -165,3 +165,42 @@ extend_target(XcbQpa CONDITION QT_FEATURE_fontconfig AND QT_FEATURE_xcb_native_p
LIBRARIES
Freetype::Freetype
)
+
+# Generated from xcb-plugin.pro.
+
+#####################################################################
+## qxcb Plugin:
+#####################################################################
+
+add_qt_plugin(qxcb
+ TYPE platforms
+ SOURCES
+ qxcbmain.cpp
+ DEFINES
+ QT_NO_FOREACH
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::XcbQpaPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::XcbQpa
+)
+
+#### Keys ignored in scope 1:.:.:./xcb-plugin.pro:<TRUE>:
+# OTHER_FILES = "xcb.json" "README"
+# PLUGIN_CLASS_NAME = "QXcbIntegrationPlugin"
+# _LOADED = "qt_plugin"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:./xcb-plugin.pro:APPLE_OSX:
+# CONFIG = "no_app_extension_api_only"
+
+#### Keys ignored in scope 3:.:.:./xcb-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+# PLUGIN_EXTENDS = "-"
+
+#### TODO: xcb-static sub folder
+#### TODO: gl_integrations sub folder