summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-05-27 14:42:35 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-28 15:13:27 +0200
commite189126f1ae1d2fa2ad0f95ee2c4aa72c770a97b (patch)
tree8d9b5207e69fb3745534545e313c6859b41968cf /src/plugins/platforms/xcb/CMakeLists.txt
parentf20f0b03d57b9517ac34043b873665bd41c098d2 (diff)
CMake: Use -fapplication-extension when building Qt libraries on macOS
Needed to avoid linker warnings transformed into errors, when linking QtWebEngine with qmake mixing. ld: warning: linking against a dylib which is not safe for use in application extensions: The flag is added to libraries and plugins, unless opted out. CMake equivalent of 944110089d4cb1c229dba422989e154db65a67fd Task-number: QTBUG-83929 Task-number: QTBUG-75666 Change-Id: I3e9acca4712c9a266bf54c6e35e2fd2c0096692b Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 278ef82cb8..1d481832f1 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -64,6 +64,10 @@ qt_add_module(XcbQpa
XKB::XKB
)
+# special case begin
+qt_disable_apple_app_extension_api_only(XcbQpa)
+# special case end
+
## Scopes:
#####################################################################