summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2018-10-25 13:16:42 +0200
committerTobias Hunger <tobias.hunger@qt.io>2018-11-05 14:54:48 +0000
commitec510d0ebcaabbdfafc4eb6545150376871d5468 (patch)
treee32e8c8477dc9ff0edbea4f89715be989a7cc250 /src/plugins/platforms/xcb/CMakeLists.txt
parent465da04bcbddffdb4f66d74d5f40907fa23d3e29 (diff)
Store QT_FEATUREs that are not emitted
Store QT_FEATUREs that are not emitted, but do not show them in the UI. Also separate out the UI (FEATURE_foo) from the internal CMake value (QT_FEATURE_foo). This does break the overriding of settings, but that did not work well before either. This will be fixed in follow-up patches. Remove fallout: xkbcommon_system was now evaluated where it was not before. Remove it as that is always the case now. Change-Id: I2d303827a1cc9afeef93ad73285a2043ddaa9766 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index fc7a6eb1bf..d1fff8bf25 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -122,18 +122,6 @@ extend_target(XcbQpa CONDITION QT_FEATURE_vulkan
#extend_target(XcbQpa CONDITION NOT QT_FEATURE_xkbcommon_system
#)
-extend_target(XcbQpa CONDITION (NOT QT_FEATURE_xkbcommon_system) AND (QT_FEATURE_xkb)
- INCLUDE_DIRECTORIES
- ../../../3rdparty/xkbcommon/src/x11
-)
-
-extend_target(XcbQpa CONDITION (NOT QT_FEATURE_xkbcommon_system) AND (NOT QT_FEATURE_xkb)
- INCLUDE_DIRECTORIES
- ../../../3rdparty/xkbcommon
- ../../../3rdparty/xkbcommon/xkbcommon
- ../../../3rdparty/xkbcommon/src
- ../../../3rdparty/xkbcommon/src/xkbcomp
-)
#
#extend_target(XcbQpa CONDITION NOT NOT QT_FEATURE_xkbcommon_system
#)