summaryrefslogtreecommitdiffstats
path: root/src/plugins/sqldrivers/psql/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <albert.astals.cid@kdab.com>2019-02-12 14:34:40 +0100
committerAlbert Astals Cid <albert.astals.cid@kdab.com>2019-02-12 14:39:33 +0000
commit11acba6504560dde54e94989b84df94157f9cc00 (patch)
tree66a9bd8bf2d65dcde2b5aa4b5fe877bf88b487ac /src/plugins/sqldrivers/psql/CMakeLists.txt
parentf94fdb35376efb5d2887ecfef67595edff74cbe3 (diff)
cmake: Find and build psql plugin
Change-Id: I8cbc8ab0061f67824d78198cbb926f0625fc7e41 Reviewed-by: Liang Qi <liang.qi@qt.io>
Diffstat (limited to 'src/plugins/sqldrivers/psql/CMakeLists.txt')
-rw-r--r--src/plugins/sqldrivers/psql/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/plugins/sqldrivers/psql/CMakeLists.txt b/src/plugins/sqldrivers/psql/CMakeLists.txt
new file mode 100644
index 0000000000..f87a8108b1
--- /dev/null
+++ b/src/plugins/sqldrivers/psql/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from psql.pro.
+
+# FIXME cmake FindPostgreSQL is more exhaustive than the check we have for libpq-fe.h
+# it also checks for catalog/pg_type.h which is a more internal include, we should
+# add a way to tell cmake FindPostgreSQL to optionally only look for the libpq-fe.h one
+find_package(PostgreSQL)
+
+#####################################################################
+## qsqlpsql Plugin:
+#####################################################################
+
+add_qt_plugin(qsqlpsql
+ TYPE sqldrivers
+ SOURCES
+ main.cpp
+ qsql_psql.cpp qsql_psql_p.h
+ DEFINES
+ QT_NO_CAST_TO_ASCII
+ QT_NO_CAST_FROM_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::SqlPrivate
+ PostgreSQL::PostgreSQL
+ # OTHER_FILES = "psql.json"
+ # PLUGIN_CLASS_NAME = "QPSQLDriverPlugin"
+ # _LOADED = "qt_plugin"
+)